CVE ID:

CVE-2017-9979

Details:

On the OSNEXUS QuantaStor v4 virtual appliance before 4.3.1, if the REST call invoked does not exist, an error will be triggered containing the invalid method previously invoked. The response sent to the user isn't sanitized in this case. An attacker can leverage this issue by including arbitrary HTML or JavaScript code as a parameter, aka XSS.

References:

EXPLOIT-DB:42517
:https://www.exploit-db.com/exploits/42517/
FULLDISC:20170815 QuantaStor Software Define Storage mmultiple vulnerabilities
:http://seclists.org/fulldisclosure/2017/Aug/23
:http://packetstormsecurity.com/files/143780/OSNEXUS-QuantaStor-4-Information-Disclosure.html
:http://www.vvvsecurity.com/advisories/vvvsecurity-advisory-2017-6943.txt

ZeroDayLab Assigned Tags:

CROSS SITE SCRIPTING - What is Cross Site Scripting?