Latest Vulnerabilities and Exploits



CVE ID:

CVE-2022-23109

Details:

Jenkins HashiCorp Vault Plugin 3.7.0 and earlier does not mask Vault credentials in Pipeline build logs or in Pipeline step descriptions when Pipeline: Groovy Plugin 2.85 or later is installed.

References:

:https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2213
:https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2213
MLIST:[oss-security] 20220112 Multiple vulnerabilities in Jenkins and Jenkins plugins
:http://www.openwall.com/lists/oss-security/2022/01/12/6