Latest Vulnerabilities and Exploits



CVE ID:

CVE-2022-34295

Details:

totd before 1.5.3 does not properly randomize mesg IDs.

References:

:http://www.hit.bme.hu/~lencse/publications/JCST-Apr14-2.pdf
:https://github.com/fwdillema/totd/commit/afd8a10a6a21f82a70940d1b43cff48143250399
:https://github.com/fwdillema/totd/releases/tag/1.5.3
:https://www.usenix.org/conference/usenixsecurity22/presentation/jeitner

ZeroDayLab Assigned Tags:

CODING ERROR / DESIGN FLAW