Latest Vulnerabilities and Exploits



CVE ID:

CVE-2022-37434

Details:

zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).

References:

:https://github.com/curl/curl/issues/9271
:https://github.com/ivd38/zlib_overflow
:https://github.com/madler/zlib/blob/21767c654d31d2dccdde4330529775c6c5fd5389/zlib.h#L1062-L1063
:https://github.com/madler/zlib/commit/eff308af425b67093bab25f80f1ae950166bece1
:https://github.com/nodejs/node/blob/75b68c6e4db515f76df73af476eccf382bbcb00a/deps/zlib/inflate.c#L762-L764
MLIST:[oss-security] 20220805 zlib buffer overflow
:http://www.openwall.com/lists/oss-security/2022/08/05/2
MLIST:[oss-security] 20220808 Re: zlib buffer overflow
:http://www.openwall.com/lists/oss-security/2022/08/09/1

ZeroDayLab Assigned Tags:

BUFFER OVERFLOW
BUFFER OVER-READ