CVE ID:

CVE-2019-9956

Details:

In ImageMagick 7.0.8-35 Q16, there is a stack-based buffer overflow in the function PopHexPixel of coders/ps.c, which allows an attacker to cause a denial of service or code execution via a crafted image file.

References:

BID:107546
:http://www.securityfocus.com/bid/107546
BID:107672
:http://www.securityfocus.com/bid/107672
BUGTRAQ:20190429 [SECURITY] [DSA 4436-1] imagemagick security update
:https://seclists.org/bugtraq/2019/Apr/37
DEBIAN:DSA-4436
:https://www.debian.org/security/2019/dsa-4436
:https://github.com/ImageMagick/ImageMagick/issues/1523
MLIST:[debian-lts-announce] 20190514 [SECURITY] [DLA 1785-1] imagemagick security update
:https://lists.debian.org/debian-lts-announce/2019/05/msg00015.html
SUSE:openSUSE-SU-2019:1320
:http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00006.html
SUSE:openSUSE-SU-2019:1331
:http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00010.html
UBUNTU:USN-4034-1
:https://usn.ubuntu.com/4034-1/

ZeroDayLab Assigned Tags:

DOS
BUFFER OVERFLOW